Skip to main content
Log In | Register

TR Memescape


Topic: Zombie forum is a 404 / Current forum upgrade discussion (Read 406 times) previous topic - next topic

0 Members and 1 Guest are viewing this topic.
  • F X
  • Needs a Life
  • The one and only
  • 1,300

  • 30

Zombie forum is a 404 / Current forum upgrade discussion
http://talkrational.org/archive/

I noticed that an image in the current DDWFTTW thread was broken, and it seems the entire site is not working at the moment.
  • Last Edit: March 09, 2017, 10:44:10 AM by SkepticTank
"If you pick up a starving dog and make him prosperous he will not bite you. This is the principal difference between a dog and man."
― Mark Twain 🔭

  • 8,262

  • 1289

Re: Zombie forum is a 404
Reply #1
Damn. Same here
Love is like a magic penny
 if you hold it tight you won't have any
if you give it away you'll have so many
they'll be rolling all over the floor

  • 2,329

  • 828

Re: Zombie forum is a 404
Reply #2
Hm.

Contacting the web host.

  • SkepticTank
  • Global Moderator
  • Calmer than you are
  • 2,699

  • 449

Re: Zombie forum is a 404
Reply #3
Certainly raven has a personal backup.

  • ksen
  • Needs a Life
  • 1,348

  • 308

Re: Zombie forum is a 404
Reply #4
If she doesn't have one I'm sure Bart does.

  • 2,329

  • 828

Re: Zombie forum is a 404
Reply #5
fixed!

  • osmanthus
  • Administrator
  • Fingerer of piglets
  • 4,410

  • 917

Re: Zombie forum is a 404
Reply #6
Can't remember where you mentioned it, but there was talk of updating Elk to the latest stable version too. Had any more thoughts about that?
Truth is out of style

  • 2,329

  • 828

Re: Zombie forum is a 404
Reply #7
a few nightmares

  • osmanthus
  • Administrator
  • Fingerer of piglets
  • 4,410

  • 917

Re: Zombie forum is a 404
Reply #8
:rofl: Can't see why it would be a nightmare. It's usually just a matter of a few clicks.

Download package to admin.
Go to apply.
See if any warnings pop up.
If no warning, go ahead.*
All done.

*If warning pops up, check it out in more detail. Usually it'll be something fairly easy to deal with.
Truth is out of style

  • 2,329

  • 828

Re: Zombie forum is a 404
Reply #9
Yeah my concern is the stuff we've modified.  I don't know the elkarte code nearly as well as I did the vbulletin code (pbui).

  • osmanthus
  • Administrator
  • Fingerer of piglets
  • 4,410

  • 917

Re: Zombie forum is a 404
Reply #10
Grrmpph. :p Me go get packages. Then we find out.
Truth is out of style

  • osmanthus
  • Administrator
  • Fingerer of piglets
  • 4,410

  • 917

Re: Zombie forum is a 404
Reply #11
FFS, the update linky isn't showing in admin. It should automatically link directly to update packages. I'll go see what's up with that.
Truth is out of style

  • osmanthus
  • Administrator
  • Fingerer of piglets
  • 4,410

  • 917

Re: Zombie forum is a 404
Reply #12
Truth is out of style

  • 2,329

  • 828

Re: Zombie forum is a 404
Reply #13
I'm working on a major redesign of my blog site this week and probably next.  If it will wait until after that, I'll have time and interest in looking at upgrading TR.

  • osmanthus
  • Administrator
  • Fingerer of piglets
  • 4,410

  • 917

Re: Zombie forum is a 404
Reply #14
If the buggers have upgrade patches (real ones) it will be a ten second job most of the time. If they're going to insist on total file replacement for every minor version that's as fucking stupid as phpBB, and trashes one of SMF's best features.
Truth is out of style

  • osmanthus
  • Administrator
  • Fingerer of piglets
  • 4,410

  • 917

Re: Zombie forum is a 404
Reply #15
Ok. Found them. Turns out they've done it another way. The notification on the admin main page, in the larger of the two scrolly boxes (Latest Software Updates) has the patch name linked directly to the release page for that patch.

So "ElkArte 1.0.8 security and bug fix update" is linked to https://github.com/elkarte/Elkarte/releases/tag/v1.0.8

Which aint the way it was done in SMF, and since I haven't been much into Elk since 1.0 beta I never got the memo. Anyway it's all good. Can get patches straight from admin once you know how.

Have downloaded 1.08 and 1.09 to the TR server (c/p the patch file name to the box on the admin download page - http://talkrational.org/index.php?action=admin;area=packages;sa=servers; > Download a package by url, etc).

Have run the pre-installation check on 1.08. No problems. That patch doesn't edit any bits we've frigged around with.

Try it yourself if you like: http://talkrational.org/index.php?action=admin;area=packages;sa=browse > [ Install Add-on ]

That won't actually install it. It will just take you to the pre-installation file check page, which lists all the relevant files and notes any conflicts. If you close that page without confirming installation, no files will be touched.

Short version is that 1.08 should be a no-brainer. Once that is installed, can run the pre-installation check on 1.09. :parrot:
Truth is out of style

  • 2,329

  • 828

Re: Zombie forum is a 404
Reply #16
I'm coming up for air.  I should be able to work on this tomorrow.

  • osmanthus
  • Administrator
  • Fingerer of piglets
  • 4,410

  • 917

Re: Zombie forum is a 404
Reply #17
Work on it? :rofl: It's literally about 30 seconds per patch, if there are no conflicts with existing files. I've only left it so the rest of you can check out how it works.
Truth is out of style

  • 2,329

  • 828

Re: Zombie forum is a 404
Reply #18
cool.  Maybe I'll get to it tonight!

  • osmanthus
  • Administrator
  • Fingerer of piglets
  • 4,410

  • 917

Re: Zombie forum is a 404
Reply #19
I always chuck a site in maintenance mode before patching, even if the pre-installation check says no conflicts. So add another 30 seconds for that, and another for putting the site back to normal mode. But it's still quick and easy. :)
Truth is out of style

  • 2,329

  • 828

Re: Zombie forum is a 404
Reply #20
I've done the pre install check for 1.08

We have a fair number of users online at the moment.  I'll wait an hour or so before putting the site in maintenance mode and installing 1.08.

  • osmanthus
  • Administrator
  • Fingerer of piglets
  • 4,410

  • 917

Re: Zombie forum is a 404
Reply #21
Yeah but they're not posting much. Just put up a nice notice saying "Once normal service is resumed, please post your major drama queen rants in Town Hall. Kthnxfuckoff."
Truth is out of style

  • 2,329

  • 828

Re: Zombie forum is a 404
Reply #22
heh.

I think I'm about ready now.

  • 2,329

  • 828

Re: Zombie forum is a 404
Reply #23
1.08 installed.  no errors.

  • 2,329

  • 828

Re: Zombie forum is a 404
Reply #24
The 1.09 pre-install report looks good to me.

no errors.  Shorter list of files. 

Have a look?